امنیت و ایمن سازی روتر میکروتیک در شبکه

امنیت و ایمن سازی روتر میکروتیک در شبکه

امنیت و ایمن سازی روتر میکروتیک در شبکه

در بعضی مواقع روتر شما ممکن است به حملات شبکه ای آلوده شود که برای ایمن سازی روتر خود و جلوگیری از آسیب پذیری آن در این مقاله به دو روش پرداخته شده است.

بنابراین در صورتی که روتر شما آلوده شده باشد برای اطمینان از رفع آلودگی احتمالی و جلوگیری کردن از آسیب مجدد لازم است اقدامات زیر انجام شود.شما می توانید یکی از روشهای آمده در مقاله را برای برطرف کردن مشکل خود انتخاب کنید.

مراحل ایمن سازی و امنیت روتربرد های میکروتیک:

    • روش اول: روتر را به تنظیمات اولیه و کارخانه ای خود برگردانید و دوباره آن را به روز رسانی کنید.
    • روش دوم: در صورتی‌ نمی تونید روش اول را انجام دهید می‌توانید مراحل زیر را جهت پاک‌سازی روتر اجرا نمایید.

روش اول: بازگردانی به تنظیمات کارخانه‌ای و تنظیم مجدد روتر

1) بازگردانی به تنظیمات کارخانه‌ای

در این روش شما باید  Reset Factory کردن روتر خود آن را به تنظیمات کارخانه ای برگردانید. شما می توانید از دستور زیر برای این کار استفاده کنید.

system reset-configuration no-defaults=yes

2) بروز رسانی روتربرد میکروتیک

کانفیگ اولیه را روی روتر میکروتیک انجام دهید و به اینترنت دسترسی پیدا کنید و از دستور زیر استفاده نمایید.

/system package update
check-for-updates once
:delay 3s;
:if ( [get status] = "New version is available") do={ install }

همچنین می توانید به سایت https://mikrotik.com/download  مراجعه کرده و  متناسب ترین Package را انتخاب کنبد و با Drag کردن بر روی روترتان، بروزرسانی را با موفقیت انجام دهید.

3) غیرفعال سازی سرویس‌های غیرضروری

برای اینکه بتوانید سرویس هایی که فعلا نیاز به استفاده از آنها نداریم را غیر فعال کنید می توانید از کد دستوری ip service disable استفاده می کنید.

/ip service disable [find name=telnet]
/ip service disable [find name=ftp]
/ip service disable [find name=www]
/ip service disable [find name=www-ssl]
/ip service disable [find name=api]
/ip service disable [find name=api-ssl]
/tool bandwidth-server set enabled=no
/ip dns set allow-remote-requests=no
/ip socks set enabled=no
/tool romon set enabled=no

4) استفاده از پروتکل SSH

در صورتی که بخواهید ضریب امنیتی را در روتر بالا ببرید می توانید از پروتکل رمزنگاری SSH استفده کنید. که برای فعال سازی آن باید دستور زیر را وارد کنید.

/ip ssh set strong-crypto=yes

5) غیرفعال نمودن Package های غیرضروری

از دستور زیر برای دیدن Package های نصب‌شده و همچنین وضعیت این Package ها استفاده می شود.

/system package print

برای غیر فعال کردن  Package های غیرضروری در روتر از دستورات زیر استفاده کنید .

/system package disable ipv6
/system package disable mpls
/system package disable hotspot

6) تغییر شماره پورت سرویس‌های کاربردی

شماره پورت مربوط به سرویس‌های RouterOS با استفاده از دستور زیر قابل مشاهده می باشد.

/ip service print

برای تغییر شماره پورت مربوط به یک سرویس در روتر می توان از دستور زیر استفاده کرد.

/ip service set ssh port=1284

7) اختصاص ACLجهت دسترسی به سرویس‌های کاربردی

برای اینکه تنها تعداد مشخصی IP و یا Network به روتر دسترسی داشته باشند می توان از  Access List استفاده کرد. با کاهش تعداد IP هایی به روتر دسترسی دارند  سطوح حملات کاهش یافته و امنیت روتر افزایش می یابد .

توجه : در صورتی که  ACL را تعریف کنید دسترسی به سرویس‌ها فقط از این طریق خواهد بود.

/ip service set ssh address=192.168.1.0/24
/ip service set winbox address=192.168.1.0/24

8) ایجاد رمز عبور پیچیده برای حساب‌های کاربری

در حملات Brute Force Login در صورتی مهاجم وارد سیستم می شود که رمز عبور پیچیده نبوده و طول کمتر از 10 کاراکتردارد که این کار باعث می شود که در کمتر از چند دقیقه رمز عبور شکسته شود. در صورتی که از رمز عبوری با مشخصات زیر استفده شود می توان زمان شکستن رمز عبور را افزایش داد

  • حداقل 12 کاراکتر
  • ترکیب کارترهای عدد، حروف بزرگ و کوچک و کاراکترهای خاص
/user set admin password=#123xX&123"%

9) بلاک نمودن درخواست DNS از WAN Interface

/ip firewall filter
add action=drop chain=input comment="BLOCK DNS REQUEST ON WAN INTERFACE"
dst-port=53 in-interface=pppoe-out1 protocol=udp
آشنایی سرویس broadband

ایمن سازی و امنیت روتربرد های میکروتیک

روش دوم: در صورتی‌ نمی تونید روش اول را انجام دهید می‌توانید مراحل زیر را جهت پاک‌سازی روتر اجرا نمایید.

از انجایی که در این روش یک Attacker پالیسی ها، Rule ها و دسترسی‌های ناخواسته‌ای را در روتر ایجاد کرده و از طریق این دسترسی‌های ایجاد شده کارهای مختلفی را بر روی روتر موردنظر انجام می دهد باید به روتر موردنظر متصل شوید و به بررسی قسمت‌های مختلف برای  اطمینان از موارد ناخواسته بپردازید.

1) حذف اکانت های ناخواسته از قسمت System – Users

دقت کنید که زمان اتصال به روتر از چه نوع حساب کاربری استفاده می کنید. تمامی اکانتها را بررسی کنید و اکانتهای ناخواسته را حذف کنید

2) حذف Rule های ناخواسته از قسمت Firewall – Filter Rules

در این قسمت یک Attacker ممکن است زمانی که سطح دسترسی‌های مختلف ایجاد کند یا سرویس‌های مختلف را ببندد  کارکرد روتر در شبکه را مختل کند. به بررسی Rule های این قسمت پرداخته و موارد ناخواسته را در این قسمت حذف کنید.

3) حذف Rule های ناخواسته از قسمت Firewall – NAT

این قسمت می تواند آدرس‌های IP را به آدرس‌های مختلف ترجمه کند .همچنین از این قسمت می‌توان برای هدایت ترافیک به مقصدهای نامشخص استفاده کرد. به بررسی Rule های این قسمت پرداخته و موارد ناخواسته را در این قسمت حذف کنید.

4) حذف اسکریپت‌های ناخواسته از قسمت System – Script

با استفاده از این قسمت یک Attacker می تواند  اسکریپت‌های مختلف را در روتر شما ایجاد کند و در بازه زمانی مختلف باعث شود تا  فرمان‌های مختلفی بر روی روتر شما اجرا شود. به بررسی Rule های این قسمت پرداخته و موارد ناخواسته را در این قسمت حذف کنید.

5) حذف اجرای Script مختلف در بازه‌های زمانی مختلف System – Scheduler ناخواسته بر روی روتر

در این قسمت می توان Script مختلف را در بازه‌های زمانی برای Script ناخواسته اجرا کرد. به بررسی Rule های این قسمت پرداخته و موارد ناخواسته را در این قسمت حذف کنید.

آشنایی سرویس broadband
کارشناس ارشد مهندسی نرم افزار - بعد از اتمام دوره ماکروسافت و سیسکو و اخذ مدارک بین المللی در این حوزه شروع به فعالیت کردم
ارسال نظر

آدرس ایمیل شما منتشر نخواهد شد.