کانفیگ و ساخت Bridge در تجهیزات سیسکو

کانفیگ و ساخت Bridge در تجهیزات سیسکو

کانفیگ و ساخت Bridge در تجهیزات سیسکو

در این مقتاه ما می خواهیم به شما نشان دهیم که چگونه این امکان وجود دارد که پورت های روتر مانند یک سوئیچ در یک Broadcast Domain قرار بگیرند.

همانطور که در شکل زیر می بینید این ساریو شامل 3 روتر بوده که توسط پورت سریال به یکدیگر متصل شده اند حال ما می خواهیم بین R5 و R7 یک همسایگی OSPF راه اندازی کنیم برای اینکار ما هیچ IP Address ی روی پورت های روتر R6 کانفیگ نمی کنیم و بدن اینکه از Tunnel استفاده کنیم بین این دو روتر همسایگی ایجاد خواهیم کرد.

ایتدا می خواهیم از قابلیت Bridge استفاده کرده و پورتها را به بگیگر Bridge کنیم.برای این کار از دستورات زیر استفاده خواهیم کرد:
ابتدا به فعال کردن Integrated Routing and Bridging میپردازیم:

 

R6(config)#bridge irb

سپس پورتهایs2/0 وs3/0 را عضو Bridge Group می کنیم:

R6(config)#interface s2/0
R6(config-if)#bridge-group 57
R6(config-if)#no shutdown
R6(config-if)#interface s3/0
R6(config-if)#bridge-group 57
R6(config-if)#no sh

سپس برای اینکه از LOOP جلوگیری کنیم باید از پروتکل Spanning Tree استفاده کرده و آن را فعال کنیم .(منظور از ieee همان Spanning-Tree ساده یا 802.1D هست):

R6(config)#bridge 57 protocol ieee

با انجام کارهای بالا روتر R6  به یک سوئیچ ۲ پورت تبدیل می شود که یکی از پورت هاش S2/0 و دیگری S3/0 می باشد که قرار است به شبیه سازی پورت Ethernet بپردازد.

حال می خواهیم یک  اینترفیس مجازی  متصل به Bridge را بر روی این روتر ایجاد کنیم و به آن mac-address و IP Address اختصاص دهیم :

R6(config)#interface bvi 57
R6(config-if)#mac-address 0000.6666.6666
R6(config-if)#ip address 10.57.0.6 255.255.255.0
R6(config-if)#no sh

برای اینکه روتر بتوننه پروتکل IP رو رو این Bridge Virtual Interface روت کنه باید روتینگ IP رو روی این bridge-group فعال کنیم:

سپس به فعال کردن روتینگ IP بر روی  bridge-group می پردازیم :

R6(config)#bridge 57 route ip

این کار را برای روت کردن پروتکل IP بر روی Bridge Virtual Interface انجام می دهیم.

حال کار با روتر R6 به پایان رسید همین کارها را برای روتر R5 و R7 یز انجام می دهیم:

R5(config)#bridge irb
R5(config)#bridge 57 protocol ieee
R5(config)#bridge 57 route ip
R5(config)#int s2/0
R5(config-if)#bridge-group 57
R5(config-if)#no sh
R5(config-if)#int bvi 57
R5(config-if)#mac-address 0000.5555.5555
R5(config-if)#ip add 10.57.0.5 255.255.255.0
R5(config-if)#no shutdown
R7(config)#bridge irb
R7(config)#bridge 57 protocol ieee
R7(config)#bridge 57 route ip
R7(config)#int s3/0
R7(config-if)#no sh
R7(config-if)#bridge-group 57
R7(config-if)#int bvi 57
R7(config-if)#mac-address 0000.7777.7777
R7(config-if)#ip address 10.57.0.7 255.255.255.0
R7(config-if)#no sh

حال تست اتصال دو روتر R5 و R7را می گیریم:

R5(config-if)#do ping 10.57.0.7 repeat 30
Type escape sequence to abort.
Sending 30, 100-byte ICMP Echos to 10.57.0.7, timeout is 2 seconds:
!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
Success rate is 100 percent (30/30), round-trip min/avg/max = 23/27/33 ms

حال به فعال سازی پروتکل OSPF بر روی دو روتر R5 و R7 می پردازیم:

R5(config-if)#router ospf 1
R5(config-router)#router-id 0.0.0.5
R5(config-router)#network 10.57.0.5 0.0.0.0 area 0
R7(config-if)#router ospf 1
R7(config-router)#router-id 0.0.0.7
R7(config-router)#network 10.57.0.7 0.0.0.0 area 0

همانطور که مشاهده می کنید دو روتر با یکدیگر  همسایه OSPF ای شده اند:

R5(config-router)#do sh ip ospf ne

Neighbor ID     Pri   State           Dead Time   Address         Interface
0.0.0.7           1   FULL/DR         00:00:34    10.57.0.7       BVI57

حال می خواهیم ببینیم که روتها درست منتقل می شوند یا نه برای این کار یک اینترفیس loopback روی R7 ایجاد کرده و آن را با OSPF به R5 تبلیغ می کنیم :

R7(config-router)#int loopback 1
*Feb  4 02:02:13.745: %LINEPROTO-5-UPDOWN: Line protocol on Interface Loopback1, changed state to up 

R7(config-if)#ip add 172.16.7.7 255.255.255.0
R7(config-if)#ip ospf ne point-to-point
R7(config-if)#router ospf 1
R7(config-router)#network 172.16.7.7 0.0.0.0 area 0

با توجه به نتیجه مشاهده می کنید که درست می باشد.

R5(config-router)#do sh ip route ospf | begin Gate
Gateway of last resort is not set

      172.16.0.0/24 is subnetted, 1 subnets
O        172.16.7.0 [110/65] via 10.57.0.7, 00:00:38, BVI57
کارشناس ارشد مهندسی نرم افزار - بعد از اتمام دوره ماکروسافت و سیسکو و اخذ مدارک بین المللی در این حوزه شروع به فعالیت کردم
ارسال نظر

آدرس ایمیل شما منتشر نخواهد شد.